xboxscene.org forums

Author Topic: Problem with URL redirection to new site's content from links in old posts  (Read 1625 times)

kaos_engr

  • Recovered User
  • Newbie
  • *
  • Posts: 9

Some links in posts do no redirect to their new location on https://forums.xboxscene.org.

For example, in the first post of thread at:

https://forums.xboxscene.org/index.php/topic,96132.0.html

The link:

http://forums.xboxscene.org/index.php?showtopic=710509

goes to the site's homepage.

At some time, the format of the URL to access posts in forums.xbox-scene.com changed to:

http://forums.xbox-scene.com/index.php?/topic/710509-oz-paulbs-lba48-code/

The Wayback Machine shows a redirection was captured to access the thread:

/index.php?/topic/710509-oz-paulbs-lba48-code/.

the URL for the post of the page that the Wayback Machine captured is:

http://forums.xbox-scene.com/index.php?/topic/710509-oz-paulbs-lba48-code/

However, the thread's content on the new website is accessible at the URL:

https://forums.xboxscene.org/index.php/topic,96091.0.html




« Last Edit: June 23, 2021, 09:19:10 PM by kaos_engr »
Logged

romracer

  • Recovered User
  • Newbie
  • *
  • Posts: 2

Some links in posts do no redirect to their new location on https://forums.xboxscene.org.

For example, in the first post of thread at:

https://forums.xboxscene.org/index.php/topic,96132.0.html

The link:

http://forums.xboxscene.org/index.php?showtopic=710509

goes to the site's homepage.

At some time, the format of the URL to access posts in forums.xbox-scene.com changed to:

http://forums.xbox-scene.com/index.php?/topic/710509-oz-paulbs-lba48-code/

The Wayback Machine shows a redirection was captured to access the thread:

/index.php?/topic/710509-oz-paulbs-lba48-code/.

the URL for the post of the page that the Wayback Machine captured is:

http://forums.xbox-scene.com/index.php?/topic/710509-oz-paulbs-lba48-code/

However, the thread's content on the new website is accessible at the URL:

https://forums.xboxscene.org/index.php/topic,96091.0.html

Yes, unfortunately this is the case.  As CrunchBite noted in his post, all of the content was scraped from various websites and imported into a database.  That post database was then massaged into several tables for Simple Machines Forums.  In the import process, all of the boards, topics, categories, etc. will have been assigned new IDs related to their place in SMF.  These IDs have no correlation to IPB used by the original XS forums.

I am using a CloudFlare worker to modify HTML content that includes "forums.xbox-scene.com" and replace it with "forums.xboxscene.org".  This means most posts that link to other posts have the link modified, but the part after the / is relative to IPB and has no meaning to SMF.  SMF then shows the forum homepage.  We figured this was a better solution than leaving the original links, which don't work at all and don't resolve to a valid domain.

The CloudFlare worker could theoretically modify the path part of the URL as well.  But we'd need some sort of table that maps literally every post, category and board ID onto their equivalent in SMF.  We didn't find this feasible due to the amount of content.

Logged

Iriez

  • Administrator
  • Hero Member
  • *****
  • Posts: 1238

Some links in posts do no redirect to their new location on https://forums.xboxscene.org.

For example, in the first post of thread at:

https://forums.xboxscene.org/index.php/topic,96132.0.html

The link:

http://forums.xboxscene.org/index.php?showtopic=710509

goes to the site's homepage.

At some time, the format of the URL to access posts in forums.xbox-scene.com changed to:

http://forums.xbox-scene.com/index.php?/topic/710509-oz-paulbs-lba48-code/

The Wayback Machine shows a redirection was captured to access the thread:

/index.php?/topic/710509-oz-paulbs-lba48-code/.

the URL for the post of the page that the Wayback Machine captured is:

http://forums.xbox-scene.com/index.php?/topic/710509-oz-paulbs-lba48-code/

However, the thread's content on the new website is accessible at the URL:

https://forums.xboxscene.org/index.php/topic,96091.0.html

Glad to see you back Kaos :) I know rom answered your question and its unfortunate we could not resolve this issue. If you have any ideas on how to resolve we can always document them and put them on the to-do list, but this would would take quite a lot of labor and programming-magic.

Logged